BrOffice Calc: Preenchimento de Células Vazias

0

Apesar de ter conhecimento sobre o aumento da utilização de software livre no Brasil, às vezes a gente esquece de publicar nos blogs algumas dicas interessantes. Por exemplo, um rapaz perguntou-me via e-mail se conhecia alguma fórmula que preenchesse automaticamente células de uma planilha do BrOffice Calc. Encontrei essa dica no blog do Otto Teixeira e gostaria de deixar registrado aqui caso alguém precise.

Preenchimento de Células no Windows

Esta é a pasta de trabalho que será utilizada no tutorial (formato ODS). Este documento contém uma planilha com valores padrão e uma segunda planilha sem nenhuma informação adicional:

Através de fórmulas, vamos preencher todos os espaços vazios da planilha de forma automática. A expressão lógica para essa operação é bem simples de compreender:

  • Se for vazio, então preencher nova Planilha2 com a palavra “Texto”
  • Caso contrário, preencher valores da Planilha1

A string “Texto” deve ser substituída pela palavra que será alocada nos espaços em branco. Clique na Planilha2 e cole na célula A1 a fórmula abaixo:

 =SE(ÉCÉL.VAZIA(Planilha1.A1:I93);"null";Planilha1.A1:I93)

Substitua na fórmula as palavras Planilha1 e Planilha2 pelo nome da sua planilha de origem e destino. O intervalo A1:I93 representa o início e o fim dos registros válidos na planilha do tutorial. Arraste o cursor para duplicar a fórmula na direção horizontal; em seguida, arraste o cursor na vertical, sentido sul. Todos os vazios serão preenchidos:

Preenchimento de Células no Linux

Eu tentei replicar essa fórmula no Linux aqui em casa, mas minha cópia do LibreOffice está totalmente em inglês. Na verdade, todos os comandos do Excel/LibreOffice Calc possuem um correspondente em inglês (saiba mais sobre esse assunto através desse link).

A fórmula em inglês é quase idêntica (a compreensão fica até melhor):

=IF(ISBLANK(Sheet1.A1:I93),"null",Sheet1.A1:I93)

Arraste o cursor na horizontal e depois na vertical para completar a missão:

Missão cumprida. No passado, esses campos vazios já causaram-me problemas ao trabalhar com dados tabulares no SIG, mas consegui superar todas as difucldades. Deixe seu comentário sobre esta postagem!


Envie suas dicas e sugestões para o e-mail contato@processamentodigital.com.br

DEIXE UMA RESPOSTA